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Introduction

The Symphony SDK provides sample code that helps you to build applications to extend the functionality of
and integrate third-party products with the Symphony Server.

The Symphony Client uses these same methods to ensure quality and feature completeness. Sample
applications are included for a wide variety of use cases. Reference documentation is provided in <SDK>/
Documentation/readme.html.

@ Note: You might need to restart Symphony services before a Symphony SDK application works
correctly.

Quick start

Running a Symphony SDK application

1. Create an Senstar Xnet account.
2. Download and install the Symphony Server and Symphony Client.

3. Use a Web browser to access the Symphony Server configuration interface and add a camera to the
Symphony Server.

4. Download and install the Symphony SDK. If you install the Symphony SDK on a computer without the
Symphony Server or Symphony Client, open a command prompt in the Symphony SDK bin folder (C:
\Program Files (x86)\Senstar\Symphony SDK\bin by default) as an administrator and run
the following command:

for %$x in (*.dll *.ax *.ocx) do regsvr32 /s %x

5. Run LiveStreamTest.exe in the Symphony SDK to see live video from the Symphony Server.

Compiling a Symphony SDK application

1. Open SDK.sln in Microsoft Visual Studio.
2. Right-click LiveStreamTest in the Solution Explorer and click Set as Startup Project.
3. Press F5.

Requirements and recommendations

« The managed interfaces must be from executables that target .NET 4.5.2 or later.
e The recommended IDE is Microsoft Visual Studio 2012 or later.

« The recommended programming language is C#.

e The developer should be familiar with the Symphony Server.

« Itis recommended that you install the Symphony Server and the Symphony SDK on different
computers.

Portability

It is possible to integrate live video from the Symphony Server directly to non-Windows platforms using
GStreamer and the RESTful Symphony Mobile Bridge interface.

The portable Symphony Mobile Bridge interface is not as full featured as the Windows accessible SeerWs
interface. If you need functionality in SeerWsS from non Windows platforms, then you must develop your
own layer that provides this interface. Ported implementations of .NET will work (such as Mono), but the
referenced .NET libraries link to Windows style DLLs that require deeper platform equivalence.
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Server API overview

Server API overview
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Sample code

Sample code

Symphony Server farm connectivity

Use cases

SDK projects

Connect to a Symphony Server farm

NotificationMonitorExample

FarmTest

Video

Use cases

SDK projects

Get a list of cameras LiveStreamTest
FarmTest

Connect and render live video LiveStreamTest

Connect and render historical video LiveStreamTest

Get a historical JPG

AlarmHandlerExample

Export video

ExportVideo

PTZ cameras

Use cases SDK projects

Control PTZ on a video device LiveStreamTest
FarmTest

Load guard tour locations LiveStreamTest
FarmTest

Go to a specific guard tour location LiveStreamTest
FarmTest

Events

Use cases

SDK projects

Trigger an alarm

AddAlarmToCamera

FarmTest

Listen for alarms

AlarmHandlerExample
MobileBridge

00000
Senstar Symphony SDK Developer Guide



S=ENSTAR.

Sample code

Use cases SDK projects
Get a list of alarms LiveStreamTest
Mark an alarm LiveStreamTest

Listen for farm events

NotificationMonitorExample
NotificationMonitors
MobileBridge

Farm settings

Use cases

Retrieve farm settings

SDK projects

WebService

Execute a web service method

WebServiceConsole

Recording

Use cases

Start/stop recording

SDK projects

LiveStreamTest

FarmTest

Symphony Client control

Use cases

Switch cameras in the Symphony Client interface
using the Symphony Server API

SDK projects

VideoWall

FarmTest

Switch cameras in Symphony Client interface using
the Symphony Client API

VideoWallClient

Reports

Use cases

SDK projects

Get a heatmap

GetDensitylmageJpg

Security

Use cases

Change the currently active security profile

SDK projects

SetActiveProfile

Add/remove users

UserManagement
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Video analytics

Sample code

Use cases SDK projects

Get live XML metadata from a running analytics
engine

XMLStream

Analyze video in Symphony from a third-party video
system

Algorithmintegration

Load a Symphony Ul component in a third-party PluginHost
application

Incorporate your own analytics engine AlgoSample
Incorporate your own rules engine AlgoSample

TestRuleEngine

Incorporate your own analytics engine configuration

AlgoSampleConfiguration

Incorporate your own rules engine configuration

AlgoSampleConfiguration

Timeline
Use cases

Get timeline information

SDK projects

TimelineGetter

Navigation
Use cases

Use navigation buttons to control video

SDK projects

FarmTest

DIO rules

Use cases

Import/export DIO rules from/to a CSV file

SDK projects

AddDIORulesFromCSV
ExportDIORulesToCSV

Hardware devices

Use cases SDK projects

Get a list of all hardware devices

PSA

Add a new hardware device

PSA
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Camera usage

Use cases SDK projects

View camera-use information ClientBandwidth

Direct file access (persistence)

Use cases SDK projects

Show detailed footage file frame information PrintFootageFile
Show detailed timeline file information PrintSignalsFile
Show detailed metadata file information PrintSignals2File
Show detailed export file information PrintAiraFile
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Managed libraries

Managed libraries

The Symphony SDK uses the following managed libraries:

Component Description

Seer.Connectivity.dll

Library for connecting to the Symphony Server (usually used
indirectly by samples)

Seer.BaseLibCS.dl1l

Seer.BaseLibCS.Communication.ServerConnectionManagerfOTC"enb
server connectivity (usually used indirectly by samples)
Seer.BaseLibCS.AiraWs.Signals for Web service interface
Seer.BaseLibCS.CameraMessageStruct for structure definitions
Seer.BaseLibCS.Utils.MulticastMessage fOr constants

Core.dll

Source part of the Symphony SDK

Seer.SDK.SDKFarm fOr farm connectivity and event stream
notifications

Seer.Farm.dll

Seer.Farm.DeviceModel.Client fOr client-side device operations
and information

Seer.Farm.DeviceModel.Server fOr server-side device operations
and information

Internationalization.dll

Seer.Internationalization.Translator for language translation
into all supported languages

NotificationMonitors.dll

Source part of the Symphony SDK

Interface to the event stream that comes from the Symphony
Server

The following managed libraries are dependencies of the above libraries and likely do not need to be used
by your code directly. However, you might need to add them as references to your project. If they do need
to be added, the compiler will fail with a message stating what reference needs to be added.

® Seer.Common.dll

® DeviceModel.Dio.dll

® DeviceModel.Security.dll
® Farm.Security.dll

® SecurityLib.dll

The following managed libraries enable access to video streaming.

® AxVideoRecvCtrl.dll Wraps videoRecvCtrl.dll
* BaseIDL.d11 iS a set of COM interfaces that aid in streaming video
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Senstar Symphony SDK Developer Guide




S=NSTAR
— " -
—-— ™ Media-streaming libraries

Media-streaming libraries

Component Description

AxVideoRecvCtrl » ActiveX control that supports the Dispatch interface
e Can be used by simple applications such as VB or Web-based
applications
IvideoRecvCtrl * A COM interface exposed by axvideoRecvCtrl
e Supports richer APl when combined with tnetworkendpoint and
IHistoricalSeek

* This interface is demonstrated by the LiveStreamTest sample
¢ This is the recommended interface

OCXDll.d1l » Library that allows users ti dynamically create, use, and destroy
AxVideoRecvCtrl
OCXExe.exe * An executable that shows how to use ocxp11.d11

e Useful if you need to support multiple NVRs and need a library
with a common API for each NVR

00000
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Persistence

Persistence

Files

_FootageArchive (*.dat)

Description

Video
Audio
Overlays (decorations)

_Signals (*.dat)

Timeline data

_Signals2 (*.dat)

Metadata (usually from video analytics)

Exported movie files (*.aira)

Video
Audio
Overlays (decorations)

Database

Description

Settings « Most settings (except users, groups, and
servers)

Servers * All servers and server states in a farm

Alarms * All alarms

Senstar Xnet data

License information

ObjectCounts

Count of objects per minute (video analytics)

LineCounts

Count of line crossings per minute (video
analytics)

You can use bbupdater.exe from the command line to run SQL against the database.

dbupdater "select top 10 * from settings order by sequenceid desc"

Shows the last ten settings that have changed.

dbupdater "select * from servers"

Shows all server addresses and states in the farm.

dbupdater "select count (*)

Shows the current count of all alarms.

from alarms"

All database times are UTC encoded as the number of seconds (or milliseconds) since 1970. Run
dbconfiguration.exe to view or change the current database connection string.

00000
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Add streaming video

Add streaming video

You can use the Symphony SDK to add streaming video to a project.

1.

o s~ w N

Open the design view of the form to which you want to add the control.
From the Tools menu, click Add/Remove Toolbox Items.

Click the COM Components tab.

Select the VideoRecvCtrl Control box.

Click OK.

The ActiveX control appears in the toolbox in the Windows Forms section.

Drag the ActiveX control onto the design view.

Senstar Symphony SDK Developer Guide
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Enable panel switching

You can use the Symphony SDK to enable panel switching in the Symphony Client interface.

1.

Perform one of the following tasks:

« To switch video panels using the Symphony Server, use the FarmTest or VideoWall application.
¢ To switch video panels using the Symphony Client, use the VideoWallClient application.
Ensure that the user has Video Wall Change Panel permissions.

To register the Symphony Client in which the video panel switch will occur as a video wall client,
complete the following steps:

a) Inthe Symphony Client interface, click Settings > Video Wall.

b) Click the Video Wall Client Configuration tab.

c) Click Register current Symphony Client.

To get the panel name, complete the following steps:

a) Inthe Symphony Client interface, right-click the panel and click Settings.
b) Click the Child tab to display the panel name.

If you use the VideoWall application in the command prompt and the panel name includes a
space, surround the panel name with double quotes (e.g., "panel name").

Use one of the following IP addresses:

¢ Inthe FarmTest and VideoWall applications, use the IP address of the Symphony Server.
* Inthe VideoWallClient application, use the IP address of the Symphony Client.

Senstar Symphony SDK Developer Guide

Enable panel switching
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Get an image

You can use the Symphony SDK to get a JPEG image from a project.

1. Use the cetgpec command to generate a JPEG image and return its URL.
2. Use the cetJgrEGImage cOmmand to get the byte array of a JPEG image for a specific time and camera.

3. Use the cetJrEGImage3 command to extend the cetspEcImage command and add parameters for the
decorations.

4. Use the GetJgrEGImage4a cOmmand to extend the cetJpEcImage3 command and add parameters for the
font used on the image.

Decoration options

The following parameters determine the decorations that JPEG images include.

DecorationOptions options = new DecorationOptions (15, 0, true, 0, true);
// Pass decorations. EncodedDecorationOptions to GetJPEG* functions

// You will want to use the following DecorationOptions constructor
public DecorationOptions (int decorations, int dateFormat, bool in24HourNotation, uint
streamIndex, bool canViewPrivateVideo)
{
// BITWISE OR together the following to select decoration

// 1 = rectangles.
// 2 = messages.
// 4 = time.

// 8 = paths.

_rawDecoration = decorations;

// SET to one of the following
// 0 = yyyy/MM/dd

// 1 dd/MM/yyyy

// 2 MM/dd/yyyy

_dateFormat = dateFormat;

// True for 24 hour time format. False for 12 hour time format.
_in24HourNotation = in24HourNotation;

// 0 based stream number. The Symphony Client UI is 1 based.
_streamIndex = streamlIndex;

00000
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Activate a relay

To activate or deactivate a relay, call the following Web service method:
public void PerformAction(string username, string password, string sActionReq)

To activate a relay, sactionreq uses the following format:
<action><ServerIP>10.234.8.30</ServerIP><camera><On Relay='l' DevicelD='2"'/></camera></action>

To deactivate a relay, sactionreq Uses the following format:

<action><ServerIP>10.234.8.30</ServerIP><camera><Off Relay='l' DevicelD='2'/></camera></action>

00000
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Enable a camera tour

To enable or disable a camera tour, use the following SQL command:

declare @xml xml, @camerald int, @tourName varchar (250), @disabled int;

set @camerald = 3;

set @tourName = 'Camera Tour 2';

set @disabled = 1;

select @xml = CAST (v as xml) from settings where Type = 'Camera' and Section = 'Camera' and K =
'cameraTour' and ID = @camerald;

set @xml.modify('replace value of (/TourGroup/cameraTour [@name=sqgl:variable(''@tourName'')]/

disable/text()) [1] with sgl:variable(''@disabled'')"):;

update Settings set V = CAST (@xml as nvarchar (max)) where Type = 'Camera' and Section = 'Camera'
and K = 'cameraTour' and ID = (@camerald;

To run a batch file on the Symphony Server, pass the following command to the DB Updater utility:

dbupdater "declare @xml xml, @camerald int, @tourName varchar (250), @disabled int;

set @camerald = 3;

set @tourName = 'Camera Tour 2';

set @disabled = 1;

select @xml = CAST (v as xml) from settings where Type = 'Camera' and Section = 'Camera' and K =
'cameraTour' and ID = (@camerald;

set @xml.modify('replace value of (/TourGroup/cameraTour[@name=sqgl:variable(''@tourName'')]/

disable/text()) [1] with sgl:variable(''@disabled'')");

update Settings set V = CAST(@xml as nvarchar (max)) where Type = 'Camera' and Section = 'Camera'
and K = 'cameraTour' and ID = (@camerald;"

Senstar Symphony SDK Developer Guide
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Wrap an OCX in a DLL

1. Create an MFC DLL project:
a) Click File > New > Project.
b) Expand Visual C++ and click MFC.
c) Click MFCDLL.
d) Type ocxDLL in the Name field and click OK.
e) Click Finish.
2. Add adialog to the DLL:
a) Inthe Resource View window, right-click OCXDLL.
b) Click Add > Resource.
c) Select Dialog and click New.
d) Inthe dialog, delete the OK and Cancel buttons.
3. Change the default properties of the dialog:
a) Right-click the dialog.
b) Click Properties.
c) Change the border to none.
d) Change No Fail Create to True.
e) Change Style to True.
4. Add adialog class:
a) Right-click the dialog.
b) Click Add class.
c) Type OCXDLLDialog.h inthe Name field and click Finish.
d) Add#include "resource.h" in OCXDLLDialog.h.
5. Add the OCX control:
a) Select the dialog tab.
b) Inthe Toolbox window, right-click Choose Toolbox Items.
c) Click COM Components > VideoRecvCtrl Control.
The file is videoR~2.0CX and is located in the aira\bin directory.
d) Drag the control on to the dialog and re-size it to fill the space.
6. Add a variable to the OCX:
a) Right-click the VideoRecvCtrl control.
b) Click Add Variable.
c) Change Access to protected.
d) Inthe Variable Name field, type m_OCX.
e) Click Finish.
7. Add play and stop functions:
a) Inthe ocxbLLDialog.h file, add the following as public declarations:

HRESULT Play(unsigned long IP, unsigned short port, LPCTSTR user, LPCTSTR pass,
__int64 historicalTime);
HRESULT Stop (void) ;

b) Inthe ocxXDLLDialog.cpp file, add the following methods:

HRESULT OCXDLLDialog::Play(unsigned long IP, unsigned short port, LPCTSTR user,
LPCTSTR pass, _ int64 historicalTime)
{
HRESULT hr;
if (FAILED(hr = m OCX.Init()))
return hr;
if (FAILED(hr = m OCX.Connect (IP, port, user, pass, historicalTime)))
return hr;

00000
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if (FAILED(hr = m OCX.StartVideo()))
return hr;
return S_OK;

}

HRESULT OCXDLLDialog::Stop (void)
{
HRESULT hr;
if (FAILED(hr = m_OCX.StopVideo()))
return hr;
if (FAILED(hr = m OCX.Destroy()))
return hr;
return S OK;

}

In the OCXDLL. cpp file, add a call to AfxEnableControlContainer() in Initinstance().
Create an interface for the VideoCreate, VideoDestroy, VideoPlay, and VideoStop functions.

a)
b)
c)
d)

)
h)

In the Solution Explorer, right-click Header Files.

Click Add > New Item.

Add a new header file called OCXDLLInterface.

Copy the following code into the OCXDLLInterface header file:

#pragma once

#ifdef OCXDLL EXPORTS

#define OCXDLL API _ declspec(dllexport)

#else

#define OCXDLL API _ declspec(dllimport)

#endif

#include "OCXDLLDialog.h"

OCXDLL_ API OCXDLLDialog*VideoCreate (CWnd *parent);
OCXDLL API HRESULT VideoDestroy (OCXDLLDialog *wnd) ;

Wrap an OCX in a DLL

OCXDLL API HRESULT VideoPlay (OCXDLLDialog *wnd, unsigned long IP, unsigned short

port, LPCTSTR user, LPCTSTR pass, __ int64 historicalTime);
OCXDLL API HRESULT VideoStop (OCXDLLDialog *wnd);

In the Solution Explorer, right-click Source Files.

Click Add > New Item.

Add a C++ file called 0CXDLLInterface.

Copy the following code into the OCXDLLInterface C++ file:

#include "stdafx.h"
#include "OCXDLLInterface.h"
#include "OCXDLLDialog.h"

OCXDLL_API OCXDLLDialog*VideoCreate (CWnd *parent) ({
AFX MANAGE STATE (AfxGetStaticModuleState());
OCXDLLDialog *wnd = new OCXDLLDialog() ;
wnd->Create (OCXDLLDialog: :IDD, parent);
return wnd;

}

OCXDLL API HRESULT VideoDestroy (OCXDLLDialog *wnd) {
AFXiMANAGEisTATE(AfXGetStaticModuleState());
wnd->DestroyWindow () ;
delete wnd;
return S OK;

}

OCXDLL API HRESULT VideoPlay (OCXDLLDialog *wnd, unsigned long IP, unsigned short

port, LPCTSTR user, LPCTSTR pass, __ int64 historicalTime) {
AFX MANAGE STATE (AfxGetStaticModuleState());
return wnd->Play(IP, port, user, pass, historicalTime) ;

}

OCXDLL API HRESULT VideoStop (OCXDLLDialog *wnd) {
AFX MANAGE_STATE (AfxGetStaticModuleState()) ;
return wnd->Stop () ;

Senstar Symphony SDK Developer Guide
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10. Add OCXDLL_EXPORTS to the list of preprocessor definitions for the project:

a)
b)
c)
d)

Right-click the project.

Click Properties.

Expand C/C++ and click Preprocessor.

Add OCXDLL EXPORTS to the preprocessor definitions.

11. Add a dialog-based MFC application project:

a)
b)
c)
d)
e)

f)

Click File > Add > New Project.

Expand Visual C++ and click MFC.

Click MFC Application.

Type OCXEXE and click OK.

Click Next.

Change the application type to Dialog based and click Finish.

12. Add buttons:

a)
b)
c)

d)

In the Resource View window, expand OCXEXE > OCXEXE.rc > Dialog.
Double-click IDD_OCXEXE_DIALOG.
Delete the following items:

e OK button

» Cancel button

« TODO: Place dialog controls here text

Increase the width of the dialog windows to fit two OCX controls.
Using the toolbox, drag three new buttons to the dialog.

Change the following properties for the new buttons:

Caption: Add Video
ID: IDB_ADD

Caption: Start
ID: IDB START

Caption: Remove Video
ID: IDB REMOVE

13. Add a variable to the dialog:

a)
b)
c)
d)
e)

f)

Right-click the dialog.

Click Add Variable.

Select the Control variable box.

In the Variable Name field, type m btnadd.
Verify that the control ID is IDB_ADD.

Click Finish.

14. To add the OnBNClickedAdd, OnBNClickedRemove, and OnBnClickedStart methods to the
OCXEXEDlg. cpp file, double-click each of the new buttons.

15. Inthe OCXEXED1lg.h file:

Add the required header files and std namespace:

#include <vector>
#include "..\OCXDLL\OCXDLLInterface.h"
using namespace std;

Add the following protected member:

vector<OCXDLLDialog*> m_windows;

Senstar Symphony SDK Developer Guide
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16. Inthe OCXEXEDlg. cpp file:
Modify the OnBnClickedAdd, OnBnClickedRemove, and OnBnClickedStart methods as follows:

void COCXEXEDlg::0nBnClickedAdd ()

{

}

OCXDLLDialog *dlg = VideoCreate (NULL) ;

dlg->SetParent (this);

dlg->ShowWindow (SW_SHOW) ;

dlg->MoveWindow ( (m windows.size() & 1) * 250, (m windows.size() & 2) * 50, 250, 100);
m_windows.push back (dlg) ;

void COCXEXEDlg::0nBnClickedRemove ()

{

}

if (m windows.size() > 0) {
OCXDLLDialog *dlg = m windows.back();
m_windows.pop back() ;
dlg->SetParent (NULL) ;
VideoDestroy (dlg) ;

void COCXEXEDlg::0nBnClickedStart ()

{

}

if (m windows.size() > 0) {
// This will connect to live video on localhost (127.0.0.1), camera #1, using user

“admin” and password “admin”

VideoPlay (m windows.back(), 0x7F000001, 50010, T ("admin"), T("AlcrUF4="), 0);
}

17. Inthe OCXEXE. cpp file, call cornitialize (NnULL) after afxEnableControlContainer () iN

InitInstance ().

18. In the Solution Explorer:

a)
b)
c)
d)
e)

Right-click the OCXEXE project.
Click Project Dependencies.
Select OCXDLL as a dependency.
Right-click the OCXEXE project.
Click Set as StartUp Project.

To connect to the camera, you might need to modify the camera details for the OnBnClickedStart
method in the OCXEXED1g. cpp file.

Senstar Symphony SDK Developer Guide
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Integrate a third-party video analytic

You can use sample projects in the Symphony SDK to integrate a third-party video analytic with the
Symphony Server.

Every camera connected to the Symphony Server has its own Al Tracker service (Trackerapp.exe). The
video from the camera is decompressed and passed into Al Tracker filter (Tracker.ax), which contains
the analytic and rule engines. The analytic engine processes the video and produces XML metadata that

is passed to the rules engine. The rules engine processes the metadata and creates alarms in the Alarm
database table.

When a user configures an analytic or rule in the Symphony Server configuration interface, the Symphony
Server saves the configurations in the database. The XML strings are used to initialize the analytic and rule
engines when the Al Tracker service starts. The following is an example of the XML:

<State><DisplayText>% has been changed</DisplayText><DisplayPercentage>1</DisplayPercentage></
State>

In addition to the XML strings, there are some properties used to describe the analytic to the Symphony
Server. The following fields are of special note:

« Name: the name of the analytic displayed in the Symphony Server configuration interface

« Description: the description of the analytic displayed in Symphony Server configuration interface
« Configurable: whether the analytic has Web interface for configuration

« ConfigurableForRules: whether the analytic has a Web interface for rule configuration

« SearchSupported: flag to enable/disable searching by the metadata created by the analytic

There are two projects in the Symphony SDK that provide a sample video analytic that you can integrate
with the Symphony Server:

e AlgoSample: the video analytic and rule engine project
* ConfigureWeb AlgoSample: the video analytic and rule configuration project

If you change the names of the sample projects, the name of the configuration project must start with
ConfigureWeb for the Symphony Server to recognize the project.

The Algosample video analytic counts the number of frames that change and displays either the count or
the percentage as a decoration.

Senstar Symphony SDK Developer Guide
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10:30 AM
11:00 AM
11:30 AM
12:00 PM
12:30PM
01:00PM
01:30 P
02:00 PM
02:30 P

| cam24 2016 06 03 16 5
13

.

[Alarm - AlgoSample - Sample Frame Rule Broker

1. Download the newest Symphony SDK.
2. On the computer that hosts the Symphony Server, stop all of the Symphony services (killall 9).

3. Copythe AlgoSample.* and ConfigureWeb AlgoSample. * files from the SDK\bin\algos
folder to the . . .\Senstar\Symphony SDK\bin\algos\ folder on the computer that hosts the
Symphony Server.

4.  On the computer that hosts the Symphony Server, start all of the Symphony services (killall 5).
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5.
project as a video analytic.

Rules Licenses Sel

Integrate a third-party video analytic

In the Symphony Server configuration interface, configure the a camera to use the AlgoSample

Security

[EENPS Templates Hardware Integrations Access Devices Device Tree Carousels

Cameras >

Algo Sample

Home Position| Location  ~

Overview

Import / Export Overview
Display Type:
® Percentage of Pixels

Number of Pixels

Import [ Export

Import XML... Export XML...

Cameras
General Add-Ons
PTZ Analytic License Obtained Analytic License Requested
Core Analytics v
Video v
Privacy Mask Name Type Description
Digital 1/O ( = ]  TCPListener Other Accepts metadata into Symphony.
Add-Ons @l )  (vgosample] Other [Algo sample Plugin for 3rd Party]
Groups (C= ) Analog Video Signal Loss PC Analytic m“:i ‘;‘;:;E:? input is ene solid colour which may
Video Storage ( Automatic License Plate Recognition - Core PC Analytic  (BETA) Recognition of license plates from various regions.
( Camera Tamperin PC Analytic Detects if the video has been compromised (field of view
Auxiliary L pering Y obstruction, spray painted lens, camera position altered)
( Crowd Detection PC Analytic  Detects size and density of crowds of people
(T"% )  mage Stabllization pCanalytic  Stabiliz the video stream, when experiencing small
— movements, for use with another video analytic add-on.
( Indoor People Tracking pCanalytic  Con be used for robust people tracking in indoor
. environments.
( Left and Removed Item Detection PCAnalytic  Detects left or removed items
( Motion Detection PCAnalytic  Detects pixel changes in the scene.
‘, Outdoor Peaple and Vehicle Tracking pC Analytic | C2N be used for robust people and vehicle tracking in
. outdoor environments.
Perform auto-PTZ tracking using smooth, continuous
] PTZ Auto-Tracking PC Analytic  movements. Requires a motion tracking add-on to initially
Iocate object.
ices Security Rules Licenses Settings Web Client LogOut Help
Templates Hardware Integrations Access Devices Device Tree Carousels

Display Text:

% changed

Test the AlgoSample video analytic.

that triggers a rule.

In the Symphony Server configuration interface, create an event for the AlgoSample video analytic

The AlgosSample video analytic should trigger an alarm when the number or percentage goes above

a threshold that you set in the sample code.

Set

Rules Licenses

Rules Action Sets ~ Schedules

Rules > Events

AlgoSampleEvent
Properties
Comeras Properties

Name
AlgoSampleEvent

DS2DE422_10.234.9.213

Camera Tour / Location

Add Devices

Select video engine from those running on camera
[Algo Sample] ~

Activity Threshold
80

DS2DE422_10.234.9.213 / Camera Tour / Location

This will either be the number of pixels changed or the percent of pixels changed, depending on what is set in the analytic.

Web Client
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S=NSTAR
—-— ™ Integrate a third-party video analytic

8. Modify and compile the AlgoSample and ConfigureWeb AlgoSample projects to integrate the
third-party video analytic.
You must compile the AlgoSample and ConfigureWWeb AlgoSample projects in Release mode for
the AlgoSample video analytic to work with the Symphony Server.

9. Repeat steps 2 to 5 for the new AlgoSample and ConfigureWeb AlgoSample projects.
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Legal information

Copyright © 2021 Senstar Corporation and/or its Licensor(s). All rights reserved.

This material is for informational purposes only. Senstar makes no warranties, express, implied or
statutory, as to the information in this document.

Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights
under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval
system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or
otherwise), or for any purpose, without the express written permission of Senstar Corporation

Senstar may have patents, patent applications, trademarks, copyrights, or other intellectual property rights
covering subject matter in this document. Except as expressly provided in any written license agreement
from Senstar, the furnishing of this document does not give you any license to these patents, trademarks,
copyrights, or other intellectual property.

Senstar and the Senstar logo are registered trademarks of Senstar Corporation.

All other trademarks are the property of their respective owners.
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